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Preface

INTRODUCTION

This chapter contains general information that will be useful to know before using the 
Integrated Programming Environment. Items discussed in this chapter include:

• Document Layout

• Recommended Reading

DOCUMENT LAYOUT

This document describes how to use the Integrated Programming Environment as a 
programming tool to program devices. The document is organized as follows:

• Chapter 1. IPE Application Overview – Defines the Integrated Programming 
Environment, provides software installation requirements and upgrade proce-
dures, lists the supported tools, and provides a feature matrix.

• Chapter 2. General Setup – Discusses launching and setting up the application 
and provides Advanced Mode login and options information.

• Chapter 3. IPE Reference – Provides reference information for the menu items.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXXXXA”, where “XXXXXXXX” is the document number and “A” is the revision level 
of the document.

For the most up-to-date information on development tools, see the MPLAB® X IDE online help. 
Select the Help menu, and then Topics to open a list of available online help files.
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB X IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}
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RECOMMENDED READING

This user's guide describes how to use Integrated Programming Environment. Other 
useful documents are listed below. The following Microchip documents are available 
and recommended as supplemental reference resources.

Processor Extension Pak and Header Specification (DS51292)

This booklet describes how to install and use headers. Headers are used to better 
debug selected devices using special -ICE device versions, without the loss of pins or 
resources. See also the Header online help file.

Transition Socket Specification (DS51194)

Consult this document for information on transition sockets available for use with 
headers.
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Chapter 1.  IPE Application Overview

1.1 INTEGRATED PROGRAMMING ENVIRONMENT DEFINED

The Integrated Programming Environment (IPE) is a software application that provides 
a simple interface to quickly access key programmer features. IPE provides a secure 
programming environment for production programming.

The IPE uses the MDB (Microchip Debugger) Core and MPLAB® X IDE framework to 
provide all the programming capabilities for all Microchip programmers.

1.2 SOFTWARE INSTALLATION REQUIREMENTS

The IPE uses the MPLAB X IDE framework; MDB database, and hardware tool 
interfaces; and respective drivers to provide programming capabilities to the end user.

The following software must be installed on your PC to use the IPE application:

• MPLAB X IDE v1.85 or greater. 

• The MPLAB X IPE application (installed automatically with MPLAB X IDE).

See the IPE Release Notes for up-to-date version compatibility information.

Once you’ve installed the software, the IPE application can be accessed through the 
MPLAB X IPE icon on your desktop or startup menu. The IPE must be run as 
administrator for all features to be fully functional.

1.3 PROGRAMMING TOOLS SUPPORTED

The following programming tools work with the IPE:

• MPLAB ICD 3 In-Circuit Debugger - recommended for production programming

• MPLAB PICkit™ 3 Debugger/Programmer - for development programming only

• MPLAB PM3 Programmer - recommended for production programming

• MPLAB REAL ICE™ Emulator - recommended for production programming
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1.4 INTEGRATED PROGRAMMING ENVIRONMENT APPLICATION MODES

1.4.1 Modes

The Integrated Programming Environment application operates in two modes: 

1. Production Mode – in which you can perform all the production programming 
operations. By default, the IPE is in this mode when it is launched. Instructions 
to set the operations for the Production Mode are supplied in 
Section 2.5.6 “Production Mode” of this document.

2. Advanced Mode – a feature-rich GUI interface in which you can view and change 
the settings for programming operations, and set up secure environments for 
production programming. To enable Advanced Mode, see Section 2.3 “Setting 
Up the Programmer”. 

1.4.2 Feature Matrix

The following matrix shows the default features that are accessible in Production mode. 

However, in Advanced mode, the default behavior of Production mode can be 
changed, and features can be added or removed as per the authorized personnel’s 
discretion. (Note: For all features to be fully functional, run the IPE as administrator.)

TABLE 1-1: FEATURE MATRIX

Feature Description
Production 

Mode 
Defaults

Import Hex file loads the Hex file On

Import Environment loads the Environment file Off

Import SQTP file loads the pre-built SQTP file Off

Export Hex file saves the all memory contents into a hex file Off

Program connects to hardware tool and performs 
program operation

On

Erase erases the device On

Verify verifies the device against the memory contents 
of IPE

On

Blank Check checks that the device is blank On

Read reads the device and fills the read content in 
memory

On

Memory View

Program Memory displays the program memory contents Off

Auxiliary Memory displays the auxiliary memory contents Off

Config Memory displays the configuration memory contents Off

Flash Data displays the Flash data memory contents Off

User IDs displays the User ID memory contents Off

EEPROM displays the data memory contents Off

Memory Edit

Program 
Memory

program memory contents can be edited
Off

Auxiliary 
Memory

auxiliary memory contents can be edited
Off
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Flash Data 
Memory

Flash data memory contents can be edited
Off

Config 
Memory

configuration memory contents can be edited
Off

EEPROM data memory contents can be edited Off

User IDs User ID memory contents can be edited Off

Save Environment creates or overwrites the environment Off

View Memory 
Settings

views the memory ranges
On

Edit Memory 
Settings

changes the memory ranges
Off

View Voltage 
Settings

views the voltage values
On

Edit Voltage Settings changes the voltage values Off

Create SQTP generates the SQTP file Off

Manual Download 
Firmware

to select and download the firmware into the 
Hardware tool

On

Auto Download 
Firmware

when a tool is connected, the latest firmware 
(available in the system) will be downloaded

On

Erase All Before 
Program

erases the device before programming
Off

TABLE 1-1: FEATURE MATRIX (CONTINUED)

Feature Description
Production 

Mode 
Defaults
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Chapter 2.  General Setup

2.1 INTRODUCTION

Getting started using the Integrated Programming Environment is discussed.

• Launching the IPE Application

• Setting Up the Programmer

• Advanced Mode Login

• Advanced Mode Options

2.2 LAUNCHING THE IPE APPLICATION

2.2.1 Launching the IPE

After installing the MPLAB X IDE software, double-click on the MPLAB X IPE 
application icon found on the desktop. The IPE main window opens.

FIGURE 2-1: IPE MAIN WINDOW
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2.2.2 Multiple Instances of IPE

If you need to have multiple instances of the IPE available, refer to the MPLAB X IDE 
help. Open MPLAB X IDE, go to Help>Tool Help Contents>MPLAB X IDE Help and 
navigate to the “Before You Begin” section, then “Launch Multiple Instances of the IDE.” 
Follow the instruction and apply to the IPE.

2.3 SETTING UP THE PROGRAMMER

For programming devices, you can use any of the supported tools (see 
Section 1.3 “Programming Tools Supported”). Refer to the online help of the 
selected tool (i.e., MPLAB ICD 3, PICkit 3, etc.) for information on programming a 
device.

1. Using the Family drop-down menu, select the family of the device you wish to 
program and use the Device drop-down menu to select the device. Or, use the 
Device drop-down menu to directly select the device. 

2. Click Apply to configure the IPE to the current device (e.g., Memory View, 
checksum).

3. Connect the development tool to the PC. Attach the appropriate target board, 
device, and power. Refer to the tool’s online help for additional instructions and 
information on connecting to target boards, etc.

4. Use the Tool drop-down menu to select the tool you want to use. If more than one 
development tool is connected to the PC, select the one you wish to use (see the 
figure below).

FIGURE 2-2: SELECT TOOL

Note: An exclamation point before the tool name (as shown below) indicates that 
the USB drivers need to be updated. This will not occur with the PICkit 3. 
However, the USB drivers may need to be updated for the MPLAB ICD 3, 
MPLAB PM3, and REAL ICE. 

For information on installing the correct USB drivers for Microsoft 
Windows®, launch MPLAB X IDE and click on the MPLAB IDE v8 Users 
- IMPORTANT link, which is located on the Start Page of the Learn & 
Discover tab. Follow the instructions to install the driver; then, return to 
the IPE.
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5. Click on the Connect button (next to the Tool name) to establish a connection 
between the IPE and the tool.

FIGURE 2-3: CONNECTING THE TOOL

6. When the tool is connected, any messages or errors related to this tool will be 
displayed in the Output window.

FIGURE 2-4: OUTPUT WINDOW

7. After the tool is successfully connected, proceed to Chapter 3. “IPE Reference” 
to program the device with the IPE.
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2.4 ADVANCED MODE LOGIN

Typically, someone has been authorized to establish the settings that production will 
use for the device and tool. To input those settings, log in to the Advanced mode.

1. Select Settings>Advanced Mode to open the Advanced Mode login dialog. The 
password is case sensitive. Type in the default password microchip and click 
Log on.

FIGURE 2-5: ADVANCED MODE LOGIN

To change the password after the initial log on, click on Change Password. 

If you forget the new password, you must uninstall the IPE, delete the ipe.key file 
(located in the IPE install directory) to remove any settings made previously in IPE, then 
reinstall the IPE to begin with the default password microchip. 

FIGURE 2-6: CHANGE PASSWORD DIALOG
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2.5 ADVANCED MODE OPTIONS

Advanced mode settings must be set by someone authorized to do so. Some settings 
that are selected in these dialogs will allow a production specialist to view and control 
certain options from the Settings Menu. 

2.5.1 Operate

After validating the password to log in to the Advanced Mode, the dialog opens in the 
Operate option view. This display is similar to the main display, with the addition of 
option buttons located along the left side of the window.

FIGURE 2-7:  ADVANCED MODE, OPERATE DIALOG
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2.5.2 Power

The Power option is only available when a tool is connected. From the Advanced Mode 
dialog, click on Power to display the available settings. 

TABLE 2-1: POWER SETTINGS

Setting Description

Voltage Settings: Voltages settings will vary for different device families. All of the 
settings and parameters are similar to MPLAB X IDE.

VDD This voltage is used by the programmer to verify memory. 
The value should be the maximum voltage for the desig-
nated circuit. The default is the device's maximum voltage 
value.

VPP This is the voltage used to bring the device into a program-
ming mode. Although this is dependent on the device's 
programming specification, it may be changed.

VDD Nom The default value depends on the device. For example, 
PIC32 has 3.3V as default VDD Nom.

VDD APP This is the voltage used by the programmer to verify Flash 
memory. The default is the device's nominal voltage value.

Reset Voltages returns voltages to their default settings

ICSP Options:

Low voltage program The tool allows low voltage programming (LVP) with certain 
PICXXFXXX Flash devices. 
The Flash device selected must be capable of low voltage 
and programming must be performed in ICSP mode. 

Power Target Circuit 
from tool

This setting enables the connected tool to power the target.

High Voltage on MCLR This setting enables high voltage to be used on a Master 
Clear Reset (MCLR).
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2.5.3 Memory

From the Advanced Mode dialog, click on Memory to display the available settings. 
You can control the memory address and other parameters related to a programming 
operation. Some of the options in this window are also available on the main screen, 
for viewing and to provide easy access to these settings.

* If you wish to use any of the Preserve Memory options, first ensure that your code is 
not code-protected. For memory to be preserved, the programmer reads the section 
it needs to save, performs a bulk erase of the device, reprograms the device and 
then rewrites the area that is preserved with what was saved. Therefore, this area 
cannot be code protected.

TABLE 2-2: MEMORY SETTINGS

Setting Description

Program Memory - define the addresses to be used for range programming of the 
program memory.

   Start Address: the starting address in Hex of the program space that 
will be programmed

   End Address: the ending address in Hex of the program space that 
will be programmed

Preserve EEPROM* When the check box is selected, the device will not 
be programmed with any new data that is present in 
the memory (shown in the EEPROM window). The 
data in the EEPROM memory area on the device will 
not be erased.

Preserve Program Memory 
Range*

When the check box is selected, the program memory 
range specified in the following Program Memory 
(Start and End Address) fields will not be programmed 
with any new data.

Program Memory - define the range of program memory addresses to be pre-
served. The Preserve Program Memory Range check box must be selected to 
activate these fields.

   Preserve Start Address* the starting address in Hex of the program space that 
will be preserved

   Preserve End Address* the ending address in Hex of the program space that 
will be preserved

Reset Addresses returns addresses to default settings

Allow Tool to select memories 
and ranges

When the check box is selected, the programmer tool 
sets the memory types and ranges. If selected, the 
Program Memory fields are disabled. 

Manual select:

• Program Memory allows the tool to program program memory

• Auxiliary Memory allows the tool to program auxiliary memory

• Calibration Memory allows the tool to program configuration memory

• Boot Flash allows the tool to program Boot Flash

• User IDs allows the tool to program User IDs

• EEPROM allows the tool to program EEPROM

• Flash Data allows the tool to program Flash data



Integrated Programming Environment User’s Guide

DS50002227A-page 20  2013 Microchip Technology Inc.

2.5.4 Environment 

Environments allow you to save specific tool settings, so that all of the same settings 
can be reloaded again in a different programming session. Environments are 
supported, under all tools, as either .pen files or .pm3 files.

From the Advanced Mode dialog, click on Environment to display the available 
settings. 

TABLE 2-3: ENVIRONMENT SETTINGS

Setting Description

Environment Name the environment name you specify

.pm3 file for MPLAB PM3, select this type of file

.pen file for MPLAB ICD 3, PICkit 3 and REAL ICE tools, select this 
type of file

Description the description you use for the environment

SQTP File the SQTP file name used in the environment

Misc Files other files used in the environment, e.g., data sheets, 
instructions, etc. 
Multiple files can be selected.

Properties Click this button to display the properties of the SD card in 
the MPLAB PM3.

Format Click this button to format the SD card in the MPLAB PM3, 
erasing all of the contents.

Delete opens the Delete Environment window

Copy opens a dialog to select source and destination for copying 
environment

View opens the View Environment window

Save to PM3 SD Card saves the file to a MPLAB PM3 SD card destination

Save to PC saves file to a destination on the PC
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2.5.5 SQTP

SQTP (serial quick turn programming) is used to program a unique serial number into 
each device. This number can be used as an entry code, password or ID number. 

From the Advanced Mode dialog, click on SQTP to display the available settings. 

TABLE 2-4: SQTP SETTINGS

Setting Description

Generation Method:

Random Select this option to generate unique, random numbers for 
each part. 
Also enter the start address, number of bytes and number 
of parts in the corresponding fields.

Pseudo Random
   Seed Value (Hex):

Select this option to generate a pseudo-random set of 
non-repeating numbers based on the Hex value you enter 
in the Seed Value field. 
Also enter the start address, number of bytes and number 
of parts in the corresponding fields.

Sequential
   Start Value (Hex):
   Increment (Hex):

Select this option to generate sequential numbers based on 
the starting value specified and incrementing each number 
by the amount specified. 
Also enter the start address, number of bytes and number 
of parts in the corresponding fields.

Start Address (Hex) Enter the starting address (in hex) for the serial number.

Number of bytes (Dec) Enter the size of the serial number (in decimal). 
Make sure a large enough serial number is specified for the 
number of parts planned to program using this file. 

Number or parts (Dec) Enter the number of parts to be programmed using this file. 

Generate Click Generate to create the SQTP (.num) file.

Location:

Program Memory Select this option to load the SQTP number in program 
memory. 

EEPROM Select this option to load the SQTP number in EEPROM. 

Access Method:

RETLW Select this option to use a series of RETLW (Return Literal 
W) instructions with the serial number bytes as the literal 
data. 

Raw Data Select this option to use the raw data. 

Format for PSV If the Raw Data option is selected, selecting Format for PSV 
formats SQTP data to make it compatible with PSV (Pro-
gram Space Visibility). 
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2.5.6 Production Mode

From the Advanced Mode dialog, click on Production Mode to display the available 
Production Mode Settings. 

The Production Mode Settings dialog enables authorized personnel to select the 
options that are available during production programming. The options that are 
selected in the Production Mode Settings determine which menu items will be available 
under the File, View and Settings menus in Production Mode.

Select the appropriate settings for your production programming project by checking or 
unchecking the settings. Selecting a check box in the Production Mode Settings dialog 
causes a check mark to display in front of that option under the IPE Settings menu. 

A check mark indicates that an option has been set in the Advanced Mode. If the item 
is available and has a check mark, then the production specialist can control this item 
by toggling it on or off. 

TABLE 2-5: PRODUCTION MODE SETTINGS

Setting Description

Production Mode Settings

Allow Export Hex enables a production specialist to export Hex files
If checked, this option displays under the File>Export 
menu.

Allow Import Hex file enables a production specialist to import Hex files. 
If checked, this option displays under the File>Import 
menu.

Allow Import Environment enables a production specialist to import environments. 
If checked, this option displays under the File>Import 
menu.

Allow Import SQTP file enables a production specialist to import SQTP files. 
If checked, this option displays under the File>Import 
menu.

Generate Reports enables reports to be generated. 
If Generate Reports is checked, click on Browse to set 
the location where the reports will be placed. 

Limit the Program Count to If selected, this option limits the pass, fail and total 
counts to the value that is entered into the associated 
field. 
This actually halts further programming operations 
from occurring. 
To clear the counts on the main window, click Reset 
Counters.

Allow “Verify Device ID 
before Program” under the 
Settings menu

activates this option in the Settings menu and enables 
a production specialist to control this option
This setting is valid only for tools that are capable of 
performing this function, e.g., MPLAB PM3. 

Allow “Auto Download Firm-
ware” under the Settings 
menu

If selected, this option displays in the Settings menu 
and can be controlled by a production specialist. 
If it is not selected, the IPE automatically downloads 
the latest firmware for the tool, if needed.

Allow “Erase All before Pro-
gram” under the Settings 
menu

If selected, this option displays in the Settings menu 
and can be controlled by a production specialist. 
If it is not selected, the production specialist cannot 
control this option from the Settings menu.
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Allow “Communication” 
under the Settings menu

If selected, this option displays in the Settings menu 
and can be controlled by a production specialist. 

Remove Read button from 
main window

If this option is selected, the Read button is removed 
from the main window.

Audible notification on 
successful program com-
pletion

If selected, this option generates a sound when 
programming successfully completes.

Allow memory editing and 
filling

enables memory editing and filling of memory. 
If enabled, this option is accessed in Production Mode 
from the View>Fill Memory option.

Allow Memory View

Program Memory If this option is selected, program memory can be 
displayed in the Memory View pane on the main 
window.

Auxiliary Memory If this option is selected, auxiliary memory can be 
displayed in the Memory View pane on the main 
window.

Config Memory If this option is selected, configuration memory can be 
displayed in the Memory View pane on the main 
window. 

Flash Data If this option is selected, Flash memory can be dis-
played in the Memory View pane on the main window. 

User IDs If this option is selected, user IDs can be displayed in 
the Memory View pane on the main window. This is 
only applicable if user IDs are supported by the tool.

EEPROM If this option is selected, EEPROM memory can be dis-
played in the Memory View pane on the main window.

TABLE 2-5: PRODUCTION MODE SETTINGS (CONTINUED)
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2.5.7 Settings

From the Advanced Mode dialog, click on Settings to display the available options 
(Figure 2-8).

FIGURE 2-8: GENERAL SETTINGS OPTIONS 

TABLE 2-6: GENERAL SETTINGS

Settings Description

PICkit 3 programming 
speed

Use the slider to adjust the programming speed (see 
Figure 2-9). This option can be used to help trouble-
shoot problems by slowing the speed down to allow suf-
ficient time for signal levels. The PICkit 3 slider will slow 
down ICSP programming which may help communica-
tion problems brought upon by heavy loading on the 
ICSP lines. Microchip recommends that these lines are 
clear of any components. The programming speed con-
trol may help to program boards that already have exist-
ing components on these lines.
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PICkit 3 Programmer To 
Go

Opens the PICkit 3 Programmer To Go dialog (see 
Figure 2-10) showing the settings that will be applied 
the next time the Programmer-To-Go feature is used. 
Enter an Image Name that will be used for the image on 
the PICkit 3. Click Programmer To Go to activate. 
Refer to the PICkit 3 In-Circuit Debugger/Programmer 
User’s Guide, DS52116, for information on the Program-
mer-To-Go feature. This feature may not be supported 
on all devices.

Secure Segments

Segments to Pro-
gram

Available for only devices with CodeGuard, e.g., 
dsPIC33FJ12GP202, etc. Supported by REAL ICE, 
MPLAB ICD 3 and PICkit 3.
Select the segments to program:
• Full Chip Programming
• Boot, Secure and General Segments
• Secure and General Segments
• General Segment Only

SQTP

Disable operations if 
SQTP values are 
exhausted

Selecting the check box prohibits further programming if 
all SQTP values from the specified .num file have been 
exhausted.

Program Method This option allows you to choose the test mode entry 
method for devices. This feature is supported by the 
tools which can power the target (except for PM3).This 
setting refers to the order in which the VPP and VDD volt-
ages will be applied when programming/reading the tar-
get device. 

Apply VPP before 
VDD 
(Recommended)

This is the default setting.

Apply VDD before 
VPP

Caution is recommended when using this setting as it 
may have adverse side effects. This options is available 
only when powering the device from the debug tool.

Diagnostics

Logging Level Set the message logging level.
OFF: No logging
SEVERE: Log severe (error) messages only.
WARNING: Log warning messages only.
INFO: Log informational messages only.
CONFIG: Log configuration information only.
FINE: Log some module to module communication.
FINER: Log more module to module communication.
FINEST: Log all module to module communication.

Log File Path and name of log file.

TABLE 2-6: GENERAL SETTINGS (CONTINUED)

Settings Description
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FIGURE 2-9: PICKIT 3 SETTINGS OPTIONS 

FIGURE 2-10: PICKIT 3 PROGRAMMER TO GO DIALOG 

2.5.8 Log out

After the settings are selected, click Log out to save your settings, exit the Advanced 
Mode, and return to the main window.
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Chapter 3.  IPE Reference

3.1 IPE MAIN WINDOW

The following figure shows the main window of the Integrated Programming 
Environment. The IPE main menu contains the following menus with commands:

• File Menu

• View Menu

• Settings Menu

• Help Menu
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FIGURE 3-1: IPE MAIN WINDOW
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TABLE 3-1: IPE MAIN WINDOW FIELDS

Item Description

Select Device and Tool:

• Family filters devices by family

• Device specifies the device; click Apply to select

• Tool specified the tool; click Connect or Disconnect as 
appropriate

Results:

• Checksum checksum value for the device with current memory 
contents

• Pass Count details the programming operations that passed

• Fail Count details the programming operations that failed

• Total Count the total amount of programming operations

Command Buttons:

• Program (Alt+F5) programs the device

• Erase(Alt+F6) erases the device

• Read(Alt+F7) reads the device

• Verify(Alt+F8) performs a verify operation on the device

• Blank 
Check(Alt+F9)

checks whether the device is blank

Other:

Source the hex file location—Browse to locate the file

SQTP the SQTP file location—Browse to locate the file

More/Less display more or less information

Output Tab display of output data.
Right-click in the Output window to split the view and show 
the tools

Tool Tab display of specific tool data, i.e., PM3, ICD 3, PICkit 3
If a tool is connected, right-click in the Output area and 
select Split View to display the tool tab.

Memory View displays only if the View>Show Memory is selected
This option displays memory addresses, device ID, 
configuration memory, etc.
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3.2 FILE MENU

The File Menu provides three options: Import, Export, Exit.

3.2.1 File>Import

The Import menu item allows you to import files into the IPE:

1. File->Import->Hex – select to import the hexadecimal file (*.hex).

2. File->Import->Environment – select to import the environment (*.pen or .pm3 
file).

3. File->Import->SQTP – select to load the SQTP file (*.num file).

3.2.2 File>Export

The Export menu item allows you to export data from IPE to storage media. By default, 
these options are not available in Production Mode. However, in Advanced Mode, an 
authorized user can change the default states of this feature for the Production Mode.

File->Export->Hex – this option allows you to export all the memory contents into Intel® 
Hex file format. 

3.2.3 File>Exit

This option closes the IPE application.

3.3 VIEW MENU

The View menu options are described below:

• Show Memory

• Clear All Memory

• Fill Memory

• Memory Settings

• Power Settings

3.3.1 Show Memory

The specific kinds of memory that are shown are determined by Advanced or 
Production Mode settings. This option toggles between showing and not showing the 
memory. A check mark before the option indicates it is enabled (showing) in the 
Memory View pane located near the bottom of the window; unchecked indicates that 
the memory is not showing.
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FIGURE 3-2: MEMORY VIEW PANE

The viewable memory types are determined by the Production settings that are set in the Advanced Mode.
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FIGURE 3-3: MEMORY TYPES

If enabled, the configuration settings can be edited. Select Config Memory from the drop-down list in 
Memory View. Use the scroll bar to view the Setting column. Click the setting you want to edit and a list 
displays that shows the options that are available for that setting. Click on your selection. 

This is shown in the following figure.

FIGURE 3-4: EDITING A CONFIGURATION SETTING
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3.3.1.1 RIGHT-CLICK MENU OPTIONS

Undock/Dock – when viewing the memory window, a right-click menu is available with 
options to undock/dock, fill memory and print.

The memory window can be undocked to view a larger area in a separate window. 
Right-click on any value in the Memory View and select Undock (see Figure 3-5). 

To return the undocked window to the IPE window, either close the memory window or 
right-click and select Dock.

FIGURE 3-5: UNDOCKED MEMORY VIEW

Fill Memory – you can also access this dialog by right-clicking on any value in the 
Memory View window and select Fill Memory.

Print – to print the memory window, right-click on any value in the Memory View 
window and select Print. 

Note: this command will print the entire contents of the memory. So, if you have a large 
device, such as a PIC32, the printout will probably be quite large. You might consider 
printing to a file, rather than to a printer, in some cases.

3.3.2 Clear All Memory

Clears all of the memory views.
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3.3.3 Fill Memory

If enabled in Advanced Mode, the Fill Memory option is available in Production Mode 
under the View menu.

FIGURE 3-6: FILL MEMORY DIALOG

3.3.4 Memory Settings

Displays the current memory settings. The Memory Settings are view-only and cannot 
be changed from this window. 

3.3.5 Power Settings

Displays the current power settings.

TABLE 3-2: FILL MENU OPTIONS

Setting Description

Start Address start address of the fill operation

End Address end address of the fill operation

Data the value used for the fill operation

Use Data as Fill Value – fills each address with the Data value
Sequence Start – fills each address with incrementing Data value
Randomize – fills each address with a random value

Write writes addresses to the memory view

Close exits the dialog
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3.4 SETTINGS MENU

The Settings menu provides access to the Advanced Mode. Select Settings>Advanced 
Mode to display the login dialog. Once the login is validated, additional settings can be 
set by an authorized personnel. 

Refer to  “Setting Up the Programmer” and  “Advanced Mode Options”.

3.4.1 Understanding the Settings Display

Menu options are shown as active or unavailable (grayed out). 

Menu items that are active and have a check mark indicate that the Production can 
control these settings. 

Menu options that are unavailable and have a check mark indicate that these options 
have been set in Advanced Mode, but that production personnel cannot control these 
settings. 

Menu items that are active and do not have a check mark indicate that the authorized 
personnel can access them. 

Menu options that are not enabled for the Production mode are shown as grayed menu 
items.

* The download of firmware will not occur until the connect/disconnect button is clicked or 
a programming operation is performed.

TABLE 3-3: SETTINGS MENU OPTIONS

Setting Description

Advanced Mode This option opens the Advanced Mode login dialog. 
Refer to  “Setting Up the Programmer” and  “Advanced 
Mode Options” for more information.

Verify Device ID Before 
Program

This option is only appropriate when using devices that 
have device IDs.

Erase All Before 
Program

This option is used to control whether or not the contents of 
the device will be erased before it is programmed. 
It is not applicable to One-Time-Programmable (OTP). 
When the “Erase All Before Program” option is enabled 
(check box is checked), the device will be erased before it is 
programmed. 
If it is disabled (unchecked), the device will not be erased 
before it is programmed 

Auto Download 
Firmware*

If this option is selected, the application verifies the firm-
ware is the latest available; and, if needed, downloads the 
newer firmware automatically. 

Manual Download 
Firmware*

This option enables manual download of firmware.

Hold on Reset prevents the code from running after programming

Release from Reset removes the Reset and allows the code to run

Communication This option enables communication to be set for COM or 
USB ports.
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3.5 HELP MENU

The Help menu provides access to the online user’s guide and information about the 
program.
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Support

INTRODUCTION

Please refer to the items discussed here for support issues.

• Warranty Registration

• The Microchip Web Site

• myMicrochip Personalized Notification Service

• Customer Support

WARRANTY REGISTRATION

If your development tool package includes a Warranty Registration Card, please 
complete the card and mail it in promptly. Sending in your Warranty Registration Card 
entitles you to receive new product updates. Interim software releases are available at 
the Microchip web site.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at http://www.microchip.com. This 
web site is used as a means to make files and information easily available to 
customers. Accessible by using your favorite Internet browser, the web site contains 
the following information:

• Product Support – Data sheets and errata, application notes and sample 
programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

myMICROCHIP PERSONALIZED NOTIFICATION SERVICE

Microchip's personal notification service helps keep customers current on their 
Microchip products of interest. Subscribers will receive e-mail notification whenever 
there are changes, updates, revisions or errata related to a specified product family or 
development tool.

Please visit http://www.microchip.com/pcn to begin the registration process and select 
your preferences to receive personalized notifications. A FAQ and registration details 
are available on the page, which can be opened by selecting the link above.

http://www.microchip.com/pcn
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When you are selecting your preferences, choosing “Development Systems” will 
populate the list with available development tools. The main categories of tools are 
listed below:

• Compilers – The latest information on Microchip C compilers, assemblers, linkers 
and other language tools. These include all MPLAB C compilers; all MPLAB 
assemblers (including MPASM™ assembler); all MPLAB linkers (including 
MPLINK™ object linker); and all MPLAB librarians (including MPLIB™ object 
librarian).

• Emulators – The latest information on Microchip in-circuit emulators.These 
include the MPLAB REAL ICE in-circuit emulators

• In-Circuit Debuggers – The latest information on Microchip in-circuit debuggers. 
These include the MPLAB ICD 3 in-circuit debuggers and PICkit 3 debug express.

• MPLAB X IDE – The latest information on Microchip MPLAB X IDE, the 
Windows® Integrated Development Environment for development systems tools.

• Programmers – The latest information on Microchip programmers. These include 
the device (production) programmers MPLAB REAL ICE in-circuit emulator, 
MPLAB ICD 3 in-circuit debugger, MPLAB PM3, and PICkit 3 development 
(nonproduction) programmer.

• Starter/Demo Boards – These include MPLAB Starter Kit boards, PICDEM demo 
boards, and various other evaluation boards.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Technical Support

Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document. See our web site 
for a complete, up-to-date listing of sales offices.

Technical support is available through the web site at http://support.microchip.com.

Documentation errors or comments may be emailed to docerrors@microchip.com.

http://support.microchip.com
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